1. Hello Guest, welcome to our little Switch Forum! Our intention here is to create the best Nintendo Switch community on the internet, as well as keeping you informed with the latest developments. Registration is FREE, so get yourself logged in and join us!
    Dismiss Notice

ZD controller

Discussion in 'Switch General Discussion' started by Kevin Keaney, Jan 16, 2018.

  1. Kevin Keaney

    Kevin Keaney New Member

    Hi All,

    Still struggling with this ZD controller. Their website is www.izdtech.com but when I try to update the firmware I get this message “It is a different product, the firmware is not matched. Can’t update it”.

    I am following the poor tutorial on their website but still no joy.

    Any help appreciated.

    The controller details below

    ZD-T[Bluetooth+motion control] pro Wireless Gaming Controller for Nintendo Switch,... https://www.amazon.co.uk/dp/B0777GTQLK/ref=cm_sw_r_sms_c_api_t2DxAb7AFHJ52
  2. nacsgaming

    nacsgaming Senior Member

    Wish I could help you with that but I am not familiar with their controllers.
  3. Joecool

    Joecool Well-Known Member

    I see that you got the ZD-T Bluetooth Controller.
    Their website references the other models they have.

    If you tried the firmware/drivers for ZD-T(Bluetooth), maybe their links are wrong.
    You can try the other firmware for the other controllers see one that works?
  4. jimothy

    jimothy Well-Known Member

    I got the same controller for my birthday today :D

    Got it to work almost first time. This is what I did:

    First time, I had it plugged into the the USB, tried the Home+X button press, and nothing was happening.

    But, after I disconnected the controller from the cable, then held down Home+X, I got the flashing lights, then lights 1+4 to show Switch mode, and then it connected up and all seems to be good. I think I held the buttons down for longer than the prescribed 5-10 seconds. Didn't have to do any firmware updates or anything. Seems that it doesn't respond if it's plugged in.

    Any help? I guess you've probably already tried all manner of combinations. Maybe you got a faulty one?
  5. Georgina Howlett

    Georgina Howlett Moderator Staff Member

  6. jimothy

    jimothy Well-Known Member

    Gah! Since the 5.0.0 upgrade my Switch immediately crashes if I try and connect the ZD-T controller :-( it was going so well too.

    Internet wisdom says it's the con-colour update - Switch is asking what colour is the controller, cheapo controller says I have not the foggiest, Switch crashes.
    Just checked the controller website for any firmware update. Looks like its still dated 2017 so I assume unlikely to fix the crash.

    Surely Nintendo should issue a patch? They might not be keen on the use of unofficial 3rd party peripherals but they shouldn't leave the Switch in a state that it just collapses.

    Anybody else had troubles with 3rd party controllers since the update?
  7. Miah

    Miah Active Member

    Yeah, seen a lot of comments about that going on. It would be nice of Big-N to work things over, but they would be well within their rights to say "it's on the other party to patch their device firmware to bring it up to our spec." Sadly on low-budget or no-name-cheapo-china devices i think controller firmware updates are somewhat less likely to occur.
  8. jimothy

    jimothy Well-Known Member

    Yay. Working again.
    A new firmware update appeared on the ZD website, which with some trepidation I ran (Sophos was not happy about it at all! But I ran it anyway)

    My un-official Pro controller is back in action again :)

    Which means that now I am no longer contemplating having to buy a Ninty Pro controller this month, I can get a new game instead.......
    Fintendo likes this.

Share This Page